Bug #7687

Custom port setting in ChatSecure-b198db53 does not save (reliably)

Added by Anonymous over 1 year ago.

Status:NewStart date:06/23/2016
Priority:NormalDue date:
Assignee:-% Done:


Target version:-


I run ChatSecure-b198db53 (installed from f-droid) on a samsung-s5 (SM-G900F) with CM 12.1 (20151007 stable). I (want to) connect to an ejabberd-server that runs c2s on the standard-port (5222) and on port 1111. My plan was to normally use the standard port and to use port 1111 when i'm behind a firewall - just change settings (5222 to 1111) inside the firewalled network. thist change of settings was never accepted reliably, so i deleted the account on my phone, re-installed chatsecure and added another account which had the port-setting (1111) from the beginning.
this only worked outside the firewalled network (where port 5222 works anyway); inside the firewalled network ChatSecure deleted the setting and again tries to connect to port 5222. i tried logging out and in numerous times and changing the setting bewtween; i killed the (two) ChatSecure-related processes before changing the setting but ChatSecure will not connect to port 1111.

(If it helps any i can provide the ejabberd-logs.
The firewalled network i'm inside only allows traffic to some ports (1111 among them) and i can telnet to the ejabberd-server:1111 from my phone.)

Maybe Bug #4679 should be reopened.

Also available in: Atom PDF