Bug #3471

14.0.0-RC3 continues to lock up Samsung Android 4.4.2 when WiFi enabled

Added by Anonymous over 3 years ago.

Status:NewStart date:06/08/2014
Priority:UrgentDue date:
Assignee:-% Done:


Category:-Spent time:-
Target version:-


ongoing saga of orbot-over-WiFi woe since Samsung Android 4.4.2 on GS4. worked fine with Android 4.3 on same GS4.

orbot completely locks up Android UI whenever WiFi is enabled. near immediate loss of access to Android Settings screen. complete Androud UI lockup after GS4 display blanks to conserve power. long press-hold on power button or battery pull required to recover Android.

orbot works AOK over 3G/4G, unrooted, but then only with proxy-aware apps.

orbot can't start using Android IPtables, at all, stopping after control port 9051, with or without WiFi enabled. (new bug?)

sockstat shows no port conflicts with any other apps/processes. com.sec.mts.nsc.android.proxy is manually disabled. Samsung Link (aka AllShare) is disabled. still no joy with WiFi.

does this problem have anything to do with Android changes to "webview?"

Also available in: Atom PDF