Bug #2916

Mac OS X Keysync installed via pip can't find 'otrapps' module

Added by hans almost 4 years ago. Updated almost 4 years ago.

Status:NewStart date:01/28/2014
Priority:NormalDue date:
Assignee:-% Done:


Target version:0.2.1


I have the same symptoms on Mac OS X. When I run /Applications/KeySync.app/Contents/Resources/keysync-gui I get a error that module qrcode is not found. After installing that, I get the same for PIL, after that, I get the same for otrapps, which pip can't find, so I'm stuck there.

When I start the application normally I get the UI that seems to work fine until you hit the button and it disables all interface elements and just hangs.


#1 Updated by hans almost 4 years ago

  • Subject changed from Mac OS X Keysync can't find 'otrapps' module to Mac OS X Keysync installed via pip can't find 'otrapps' module

#2 Updated by hans almost 4 years ago

FelixAkk, seems like pip didn't install everything correctly. otrapps is included as part of the keysync package, so if you have keysync-gui, you should have otrapps. Can you add more information on how you installed keysync?

#3 Updated by FelixAkk almost 4 years ago

I believe it was from the frontpage of the keysync website using the URL in the Mac OSX section (https://guardianproject.info/releases/KeySync-0.2.app.zip). It didn't say anything about other installation steps for the .app, so I assumed the regular method of installing on Mac OSX (just copying to the applications dir).

Perhaps useful; when I run a 'pip install otrapps' I get a 'Could not find any downloads that satisfy the requirement otrapps', so I can imagine that a lot of users won't know how to get the required dependencies. Certainly not ordinary users that know just to drag-drop the .app around and then run it. Anyways, really hope this get's solved soon!

Also available in: Atom PDF